「.\conf\Ports.properties(アクセスが拒否されました。)」のエラーメッセージが表示され、OpManagerが停止した。
作成日:2015年7月2日 | 更新日:2023年2月3日
現象
「.\conf\Ports.properties(アクセスが拒否されました。)」のエラーメッセージが表示され、OpManagerが停止した。
原因
OpManagerは起動する際にport.propertiesファイルを更新しますが、
本ファイルへのアクセスを拒否されたため本エラーが発生します。
主な原因の1つと致しましてOpManagerが正常に停止されていなかった可能性があります。
※バッチ処理で一定期間ごと(もしくは毎日深夜0時に、等)にバックアップを取得するよう
タスク化している場合に発生しております。
解決方法
以下、ご確認頂けますでしょうか。
【1】OpManagerを管理者権限で起動していない、
もしくはOpManagerフォルダに読み取り/書き込み権限を付与されているか確認
【2】logs/wrapper.logに
「WEBサーバへの接続に失敗しました。OpManagerをシャットダウンしてください。」のエラーが発生している。
サーバを起動している際にWEBサーバへの接続に失敗しています。
そのため、OpManagerが起動できずシャットダウンされ、サービスが停止したと考えられます。
以下の点についてご確認頂けますでしょうか。
1) バッチ処理のタスクは管理者権限で実行するよう設定されているか。
2) DBのフォルダをアンチウイルスの検索から除外しているか。
【3】JVMエラーとメモリ不足によるエラーが発生している。
仮想メモリと物理メモリ、またHDDの空き容量を確認します。
なお、仮想メモリは物理メモリの2倍程度確保するのが一般的となっております。
つきましては以下の手順を実施し、仮想メモリのページングファイルのサイズの
手動での変更をご検討頂けますでしょうか。
手順)
Windows OSの[コントロールパネル] - [システムとセキュリティ] - [システム] - [システムの詳細設定] - [詳細設定] -パフォーマンスカテゴリの[設定] -
[詳細設定]タブ - 仮想メモリカテゴリの[変更]より「初期サイズ」と「最大サイズ」を手動で入力し、設定。
併せて以下の弊社公式HP、ナレッジよりサーバのサイジングの目安をご確認ください。
OpManager の動作環境、システム要件
https://www.manageengine.jp/products/OpManager/system-requirements.html
【対応リリース】 x.x